[Openswan Users] ipsec-tools required on 2.4 based kernel?

Paul Wouters paul at xelerance.com
Mon Jan 24 19:53:31 CET 2005

On Mon, 24 Jan 2005, Shaheen Ali wrote:

> I have a new question.  When I attempt to install openswan-2.2.0 binaries
> on a RH9 system (2.4 based kernel, 2.4.20-6), it complains that I require
> ipsec-tools.  Should I ignore this with the forced option?  When I try to
> install ipsec-tools I get an error that kernel 2.6 is required.
> I must be doing something wrong.  Does openswan-2.2 really support 2.4
> kernel?

RH9 requires that you also build the KLIPS ipssec stack. Please build your
own binary rpms from the openswan-2.3.0 src.rpm, eg:

Grab   ftp://ftp.openswan.org/openswan/binaries/fedora/3/SRPMS/openswan-2.3.0-1.src.rpm

rpm -ihv openswan-2.3.0.src.rpm
rpmbuilds -bb /usr/src/redhat/SPECS/openswan.spec --define 'buildklips 1'

Then install the openswan binary rpm and the openswan-klips rpm.


"At best it is a theory, at worst a fantasy" -- Michael Crichton

More information about the Users mailing list