[Openswan dev] Fedora 9 rpmbuild on 2.6.14 doesn't...

Michael H. Warfield mhw at WittsEnd.com
Mon Jun 9 11:30:51 EDT 2008

On Mon, 2008-06-09 at 11:01 -0400, Michael H. Warfield wrote:
> Just tried building rpms for 2.6.14 on my Fedora 9 system and it blows
> chunks complaining about "second %prep".  Diff of the spec files between
> 2.6.13 and 2.6.14 are rather massive.  Tried it both with -ta on the tar
> file and -ba after extracting the fedora .spec file.

> [root at kolvir SPECS]# rpmbuild -ba openswan.spec 
> error: line 291: second %prep

	Looks like I may have gotten the wrong .spec file, although looking at
my shell history, I don't see how.  I recopied the Fedora .spec file
from the package and the -ba works.  The -ta against the .tgz file still
doesn't but I think that's because it's getting the wrong .spec file.
But rpmbuild -ta does work on F8, so it's something peculiar about F9.

	Now it gets past that but bombs the build with this:

cd /home/mhw/rpmbuild/BUILD/openswan-2.6.14/programs/_confread/ && cat
`cat /home/mhw/rpmbuild/BUILD/openswan-2.6.14/programs/_confread/d.ipsec.conf/order.txt` >ipsec.conf.5.xml
man /home/mhw/rpmbuild/BUILD/openswan-2.6.14/programs/_confread/ipsec.conf.5.xml 
xmlto: input does not validate (status 1)
/home/mhw/rpmbuild/BUILD/openswan-2.6.14/programs/_confread/ipsec.conf.5.xml:1231: parser error : Opening and ending tag mismatch: para line 1228 and refsect2
/home/mhw/rpmbuild/BUILD/openswan-2.6.14/programs/_confread/ipsec.conf.5.xml:1232: parser error : Opening and ending tag mismatch: para line 1221 and refsect1
/home/mhw/rpmbuild/BUILD/openswan-2.6.14/programs/_confread/ipsec.conf.5.xml:1964: parser error : Opening and ending tag mismatch: refsect2 line 1220 and refentry
/home/mhw/rpmbuild/BUILD/openswan-2.6.14/programs/_confread/ipsec.conf.5.xml:1966: parser error : Premature end of data in tag refsect1 line 216

/home/mhw/rpmbuild/BUILD/openswan-2.6.14/programs/_confread/ipsec.conf.5.xml:1966: parser error : Premature end of data in tag refentry line 5

make[3]: *** [ipsec.conf.5] Error 1
make[3]: Leaving directory
make[2]: *** [install] Error 1
make[2]: Leaving directory
make[1]: *** [install] Error 1
make[1]: Leaving directory
make: *** [install] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.84559 (%install)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.84559 (%install)

	This also seems to build just fine on F8 while it bombs on F9.  So,
again, something peculiar to F9.  Tried on two F9 systems.

Michael H. Warfield (AI4NB) | (770) 985-6132 |  mhw at WittsEnd.com
   /\/\|=mhw=|\/\/          | (678) 463-0932 |  http://www.wittsend.com/mhw/
   NIC whois: MHW9          | An optimist believes we live in the best of all
 PGP Key: 0xDF1DD471        | possible worlds.  A pessimist is sure of it!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 307 bytes
Desc: This is a digitally signed message part
Url : http://lists.openswan.org/pipermail/dev/attachments/20080609/d9bf948f/attachment.bin 

More information about the Dev mailing list