[Openswan dev] BUG 1201: dpd + ddns does not work

Tuomo Soini tis at foobar.fi
Thu Mar 29 13:11:49 EDT 2012

On Wed, 28 Mar 2012 11:38:03 +0530
Nrupen Chudasma <nrupen at gmail.com> wrote:

> Hi,
> Yesterday I sent the same comment in the User's list. But I think it
> would be appropriate to discuss about the bug in dev list.
> I have been using openswan 2.6.24 with NETKEY for quite a long time.
> I had a requirement for DYNDNS based remote host support for making
> the connections. As there is support added, I tried with the 2.6.24
> version and could not succeed.
> I searched out for bug#1201 with the exact reason. So I uprated to
> version 2.6.33. But the problem is still there. Even I tried latest
> version i.e. 2.6.38 but the result is same.
> According to the RCA done for the bug, "conn->dnshostname" is NULL.
> The specified solution was to work with ipsec whack.
> I tried with that. Please correct me if my approach for the problem is
> wrong. I have put remote as "ddnstest" and added entry in
> the /etc/hosts file.
> I add one connection with ipsec whack. Initiate the connection. Later
> I change my remote host's IP and add the according entry
> in /etc/hosts. The dpdtimeout happens as the former IP no longer
> available and thus I get the DPD in which case my action restart
> triggers the initiation of the connection.
> Still my connection is initiated to the same IP as before.

Anything in /etc/hosts is static data - not dynamic dns - there is no
guarantee it gets read without restarting whole pluto.

Tuomo Soini <tis at foobar.fi>
Foobar Linux services
+358 40 5240030
Foobar Oy <http://foobar.fi/>

More information about the Dev mailing list