[Openswan dev] openswan 2.6.24 and kernels > 2.6.31 mostly working

Paul Wouters paul at xelerance.com
Sun Dec 27 18:48:57 EST 2009

On Wed, 23 Dec 2009, David McCullough wrote:

I wrote:

>> - I tried a few kernels (2.6.31, 2.6.26, 2.6.25) and they worked. But as old as 2.6.21
>>    is broken (possibly 2.6.22/23 as well). Some macros needs additional tuning for this.

The header_ops vs hard_header() changes broke compiling on 2.6.23 and
older. I think we're supposed to supply our own header_ops struct for
those kernels, with the proper function pointers in it, but we seem to
not do that consistently. It breaks in ipsec_tunnel.c.

After this code introduction, we have the missing leading bytes issue with
tcpdump on ipsecX, though the packets decrypt fine and everything works.

I suspect these two issues are related. I tried testing this with Michael's
tree, but that one blew up on my in various other ways on kernels between
2.6.24 - 2.6.28. It also suffers the problem of not working on kernels
2.6.23 and older.


More information about the Dev mailing list