[Openswan dev] [Openswan Users] trying to configure XAUTH as replacement for working Cisco VPN Client

David Lawless lawless at spamcop.net
Thu Apr 5 10:30:05 EDT 2007


The fellow who had built 2.4.8rc1 for 'openwrt' has not offered 
to share his code, and I don't have time to dedicated to the
cross-compile and integration effort, especially as the Cisco VPN 
Client works fine.  So haven't tried it.  Guess we have to 
wait for the next version of 'openwrt', which could be many 
months out.  Apparently a Linux version of the Cisco client 
exists, and I many try to obtain a copy of that.


At 11:36 AM 4/5/2007 +0200, Marcus Carlson wrote:
>Did you successfully connect to cisco using groupname using 2.4.8rc1? 
>And what config settings did you use? I've tried the same as you wrote 
>but received different errors.
>David Lawless wrote:
>> Hello,
>> Here's the config.  I've been using the commented lines in the
>> second case above.
>> version 2.0
>> config setup
>>         interfaces=%defaultroute
>>         nat_traversal=yes
>>         klipsdebug=none
>>         plutodebug=none
>> conn Connection
>>         left=             %defaultroute
>>         leftid=           @GroupName
>>         leftxauthclient=  yes
>>         right=            R.R.R.R
>>         rightsubnet=      R.R.R.H/32
>>         rightxauthserver= yes
>>        #aggrmode=         yes
>>        #ike=              aes128
>>        #esp=              3des-sha1-96
>>         authby=           secret
>>         xauth=            yes
>>         auto=             add

More information about the Dev mailing list